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1. Introduction 

1.1 Webtec C2000 

The Webtec C2000 system is designed to provide a versatile and customisable hardware 

and software package for the measurement, logging and analysis of test data from the 

Webtec range of fluid measurement sensors. 

The hardware consists of the C2000 Midbox, housing a customisable data acquisition and 

conditioning system, accepting up to 64 analogue channels, 48 digital channels, or a 

selective range of the two. The C2000 Midbox can sample each line at up to 2kHz
*
, even 

when all channels are connected. Expansion of C2000 Midbox systems with only a few 

channels is easily achieved with the simple addition of extra modules. The on-board 

software automatically detects the hardware configuration on boot-up, making it 

available without the need for any user reconfiguration. 

 

Figure 1.1 Simplified schematic of the C2000 Midbox 

The C2000 software installs on a standard networked PC. The application compliments 

the Midbox system by automatically synchronising its own configuration to suit the 

connected hardware. Three configurable display panels are available for generating 

customised layouts, plus a fourth panel for graphical representations. These are 

complimented by report generation and analysis tools. 

This guide describes the operation of the C2000 software application, with basic 

coverage of the hardware system. For more technical guidance, and all other queries, 

please refer to the companion document [ref 1]. 

The following conventions are used in this guide: 

»  The » symbol denotes navigation through a series of linked menu items. 

                                                 

*
 Nominal maximum sampling rate 
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monospace Text in this format denotes a filename, numeric or string entry field 

Bold  Text in this format denotes a menu selection or item 

italic Text in this format denotes a noteworthy point 

 



 

Page 6 

2. References 
Intentionally left blank. 



 

Page 7 

3. Getting Started 
The C2000 software always starts up with the last used layout configuration. When no 

layout exists, such as on the very first launch following installation, the C2000 software 

will instead show an empty layout screen. In this case, it is necessary to define and save a 

layout and channel configuration before data acquisition can be performed. 

A layout contains all the definitions and settings associated with your use of the C2000 

software, such as channels and panel designs. Test data files are also stored alongside the 

layout definition on your computer. Refer to section 5 Layouts for more information on 

Layouts. 

 

3.1 Module Hardware Setup (Flow, Press & Temp) 

3.1.1 Midbox Iss’ A and B (No Module LEDs) 

C2000 M12input connector pin assignments are configured to work with sensors and 

cables supplied by Webtec – see table 3.1.1. To enable pressure transducers, flow blocks 

and temperature sensors to work with the C2000 system additional switch settings need 

consideration. 

Pressure transducers supplied by Webtec require specific switch settings to be made on 

each channel they are connected too. Undesirable effects on pressure signal integrity may 

occur if the input connector PCB switches are not selected appropriately. 

If the Sensors have been supplied with the C2000 system then the channels have been 

configured appropriately for the sensors ordered, provided they are connected according 

to the supplied Channel Configuration Sheet. If you wish to move the pressure sensors to 

another channel or add new pressure sensors then the switches on the back of the Module 

input connector PCB must be configured. 

To gain access to the switches the top panel of the C2000 box must be removed. There 

are eight banks of double switches on the rear of the PCB (figure 3.1.1), each mounted 

approximately behind its corresponding connector. Configure the switches: 

 

 To use the input for a pressure sensor the LEFT HAND switch should be ON 

and the RIGHT HAND switch OFF. 

 To use the input for a flow or temperature sensor the RIGHT HAND switch 

should be ON and the LEFT HAND switch can be ON or OFF. 
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Figure 3.1.1 Rear of Module input connector PCB. 

 

 

 

Channel Connections Function Hardware Config channel 

4-20mA Pin1 = +24Vs 

Pin2 = signal. 

Pin3 = signal. 

Pin4 = n/c. 

Flow, pressure, 

temperature,  

Aux-mA. 

Mod x:x 

 

NB. observe switch settings. 

TTL Pin1 = +24Vs 

Pin2 = TTL signal 

Pin3 = Gnd. 

Pin4 = n/c. 

Speed, Aux-TTL Mod x:x 

Table 3.1.1. Module input pin connections pre-2012. 

 

 

3.1.2 Midbox Iss’ C and above (LED on each Module Input Panel) 

Input connection detail has been changed to bring the C2000 in line with the Webtec 

product range of sensors, see table 3.1.2. The change improves the system setup because 

there are no hardware switches to configure.  

All sensors supplied from 2012 onwards have their pin configurations aligned with the 

C2000 inputs such that the supplied cables will work connected to any channel (NOTE: 

4-20mA & TTL modules are not compatible). However, flow sensors supplied pre 2012 
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may require an adaptor cable for compatible operation – contact Webtec sales for 

guidance. 

One further enhancement to the input connector panels is the addition of a power status 

LED located between the top two inputs, ie. 1 and 2. This confirms sensor power is 

available at the connectors when the LED is illuminated. 

 

Channel Connections Function Hardware Config channel 

4-20mA Pin1 = +24Vs 

Pin2 = n/c. 

Pin3 = signal. 

Pin4 = n/c. 

Pin5 = Gnd. 

Flow, pressure, 

temperature,  

Aux-mA. 

Mod x:x 

TTL Pin1 = +24Vs 

Pin2 = TTL signal 

Pin3 = Gnd. 

Pin4 = n/c. 

Pin5 = n/c. 

Speed, Aux-TTL Mod x:x 

3.1.2. Module input pin connections, 2012 onwards. 

 

3.1.3 High Current/Voltage Option - Hardware Information 

To enable the C2000 data logging system to record high currents such as solenoid drives 

and voltages from third party sensors this interface PCB conditions the signals to an 

acceptable range. Table 3.1.3 details the pin connections for the high current module 

input panel. 

The internal PCB has two independent current and voltage measuring channels, four 

channels in total. The channels are configured to customer requirements and can be 

scaled as follows: 

1. Current channel 1 can be scaled from ±1 to ±3Amps with the output signal set at 

12mA for zero current. 

2. Current channel 2 can be scaled from ±1 to ±3Amps with the output signal set at 

12mA for zero current. 

3. Voltage channel 1 can be scaled at 0-5 or 0-10volts with the output signal scaled 

at 4mA for zero volts and 20mA for 5 or 10volts.  

4. Voltage channel 2 can be scaled at 0-5 or 0-10volts with the output signal scaled 

at 4mA for zero volts and 20mA for 5 or 10volts.  

The two current channels are protected by appropriate fuses and have independent 

selectable low pass filters with a cut off frequency set at 5Hz (see figure 3.1.3.1 for 

location). With the links in the bottom position there is no filtering which could result in 

unstable measurements where PWM signals are involved! 

Figure 3.1.3.1 shows a photo of the interface PCB and is annotated with arrows 

indicating important user information. DO NOT adjust any of the potentiometers. 
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High Current and Voltage Interface PCB Layout. 

 
Figure 3.1.3.1 High Current and Voltage Interface PCB. 

 

1. Current channel 2 fuse. 

2. Current channel 2 low pass filter link (top position - filtering enabled). 

3. Current channel 1 fuse. 

4. Current channel 1 low pass filter link (top position - filtering enabled). 

5. Voltage channel 2 input. 

6. Voltage channel 1 input. 

 

Figure 3.1.3.2 shows a photo of the Midbox Module input panel that connects to the high 

current and voltage interface PCB. Connection details listed in table 3.1.3. 

The two current input channels have fuse fail indicators (F1 & F2) to display the status of 

the associated fuses. The LEDs illuminate when the fuse fails but only when the input 

polarity is correct (RED +ve). 
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Figure 3.1.3.2. High current & voltage input connector module. 

 

Channel Connections Function Hardware Config 

channel 

1 RED = +ve current 

BLK = -ve current 

High Current input Mod x:1 

2 RED = +ve current 

BLK = -ve current 

High Current input Mod x:2 

3 Pin1 = +24Vs 

Pin2 = V signal i/p 

Pin3 = Gnd. 

Pin4 = Gnd. 

Voltage input 

 

Mod x:3 

4 Pin1 = +24Vs 

Pin2 = V signal i/p 

Pin3 = Gnd. 

Pin4 = Gnd. 

Voltage input 

 

Mod x:4 

DATA Pin1 = 4-20mA i/p7 

Pin2 = Gnd. 

Pin3 = 4-20mA i/p5 

Pin4 = 4-20mA i/p6 

Pin5 = RS232Rx 

Pin6 = RS232Tx 

Pin7 = 4-20mA i/p8 

Pin8 = n/c 

Icount Data, M12 

connection option. 

Mod x:7 (ISO ch C) 

 

Mod x:5 (ISO ch A) 

Mod x:6 (ISO ch B or 

NAS) 

 

Mod x:8 (moisture) 

PWR Pin1 = Relay N/C 

Pin2 = +15v output. 

Pin3 = Relay common 

Pin4 = Relay N/O 

Pin5 = n/c 

Pin6 = n/c 

Pin7 = Gnd. 

Pin8 = +24v output. 

Icount Power, M12 

connection option. 

n/a 

Table 3.1.3. High current & voltage connector arrangement - Ref Figure 3.1.3.2. 
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3.2 Quick tutorial 

The following tutorial will guide you through the process of creating a new layout, 

configuring two channels of your hardware, creating a panel design, performing a log 

process and generating a report. 

3.2.1 Creating a new layout 

To create a new layout: 

1. Select File » Layout Manager from the drop down menu. 

2. The Layout Manager will appear. Select New, and enter Tutorial as the layout 

title, and select OK. 

 

Figure 3.2 Creating a new Layout within Layout Manager 

3. The new layout will be created and automatically selected. 

3.2.2 Channel configuration 

The following describes how to setup two example channels from the C2000 Midbox. 

Definitions for a current-based flow rate sensor and a pulse-type rotational speed sensor 

are described. Current measurement and frequency measurement modules are necessary 

on the C2000 Midbox to permit the configuration of these two sensors respectively. 

Note: The exact build of your C2000 Midbox will define the list of available modules and 

channels in the C2000 software, and thus may not match the items described below. 

Current type sensor: 
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1. Select Data » Configure Channels from the menu (shortcut CTRL+C) to open the 

channel configuration window. 

2. Select New in the Hard Channels section to begin defining a new hard channel. 

The Hard Channel Properties window will appear. 

3. Type Flow Rate into the Channel Name field. 

4. Select current (4-20mA) from the Signal Type list, and choose Module 1, 

Line 1 (Mod 1:1) from the Hardware Line drop down list. Note that the list of 

entries in the Hardware Line menu is determined from the C2000 Midbox setup. 

5. Select flow from the Sensor type list, and litres/min from the Engineering 

units list. 

6. Select the Calibration button to open the Channel Calibration window. 

7. We wish to use the simple calibration tools, so ensure the Advanced» button is 

not depressed. Note: The default state for the Advanced» button is not depressed. 

8. Enter 0 into the Value for 4mA field, and 400 into the Value for 20mA field. 

9. Change the Precision in decimal places to 0, and select OK. 

 

Figure 3.3 Defining a new current signal channel 

Pulse type sensor: 

1. Follow steps 1-2 above. 

2. Type Rotor Speed into the Channel Name field. 

3. Select frequency (Hz) from the Signal Type list, and choose Module 7, Line 1 

(Mod 7:1) from the Hardware Line drop down list. Note that the list of entries in 

the Hardware Line menu is specific to your C2000 Midbox setup. 
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4. Select speed from the Sensor type list, and RPM from the Engineering units 

list. 

5. Select the Calibration button to open the Channel Calibration window. 

6. We wish to use the simple calibration tools, so ensure the Advanced» button is 

not depressed. Note: The default state for the Advanced» button is not depressed. 

7. Enter 60 into the Pulses per revolution field. 

8. Change the Precision in decimal places to 0, and select OK. 

 

Figure 3.4 Configuring a new pulse input (frequency) channel 

9. Select OK on the Channel Configuration window to accept all changes. 
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Figure 3.5 The Channel Configuration window 

Depending upon the availability of modules on your C2000 Midbox, you will now see 

the two defined channels in the Hard Channels table list. If you do not have a frequency 

module in your C2000 Midbox for the second channel, instead create a second current 

sensor channel called Pressure, with units in bar. 

3.2.3 Layout design 

Navigate to the Super Panel through the drop down menu item View » Show Panel » 

Super Panel (shortcut key F1). The panel will be blank if there is no current layout 

definition. 

To enter configuration mode, select View » Configure » Configure Panels… from 

the drop down menu (shortcut key Ctrl+E). You will be prompted to enter the password 

(the password is webtec). We can now use the right mouse button shortcut menus to 

create two digital indicators and two sliding scales to represent our data. 

Use the right mouse button in the centre of the panel to open the configuration mode 

menu, and select New Digital. A new digital indicator will be created titled New 

Digital. Click and drag the indicator with the left mouse button to move it to a new 

location near to the top left corner of the panel area. Right mouse click the digital control 

to reveal the shortcut menu options for this digital control, and select Associate » Flow 

Rate. The title of the indicator will change to the name of the channel, with the 

engineering units displayed in brackets: Flow Rate (l/min). 
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Figure 3.6 Creating a New Digital Indicator 

Notice that if you have a suitable sensor connected to the Flow Rate channel, the values 

represented in the digital indicator are actual Live Data values. If you have no sensor 

connected, you will see zero. 

To create a second digital indicator, use the right mouse button in the centre of the panel 

to open the configuration mode menu and select New Digital. Another new digital 

indicator will be created. Move this indicator to somewhere just below the first indicator. 

Associate this indicator with the Rotor Speed channel. The title of the indicator will 

change to the name of the channel with bracketed default units: Rotor Speed (rpm). 

We now wish to display a slide indicator beside each of the digital indicators. To do this, 

use the right click shortcut menu and select New Slide. Move the slide to a position 

somewhere close to the right hand side of the first digital indicator. Right click the slide, 

and select Associate » Flow Rate. 

     

Figure 3.7 Creating a New Slide Indicator 

Create a second slide indicator in the same manner as the first, place it beside the other 

digital indicator, and associate it with the second channel. If you wish, you can alter the 

default range of the scale by selecting the minimum or maximum value with the mouse 

pointer and entering a new value.  

We can turn on Peak Recording for the slide indicators. Right click each slide indicator 

with the mouse and select Show Peak from the shortcut menu. The slide will now show a 

yellow tab that constantly marks the peak value of the data from the associated channel. 

Also, the title of the slide indicator now has a carat symbol at the beginning to indicate 

that peak value recording is turned on. 

   

Figure 3.8 Enabling Peak Value Recording on a slide indicator 
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Do the same for the second slide indicator. 

Finally, let’s place a title above our four indicators. Right mouse click an area of free 

space on the panel and select New Title from the shortcut menu. A new title with the 

default words New Title appears under the mouse pointer. Click and drag this title to the 

top of the super panel, centralised over the four indicators. Either triple click the title to 

select the entire contents or use the delete key to erase the existing text, and then type 

Example Super Panel. 

You should now have a Super Panel that looks similar to this: 

 

Figure 3.9 Super Panel layout example. 

Finally, select View » Configure » Configure Panels (shortcut Ctrl+E) from the drop 

down menu to exit configuration mode. When not in configuration mode, the indicators 

and titles can no longer be moved or edited. 

Select File » Save Layout from the drop down menu (shortcut Ctrl+S) to save the layout 

to the computer. 

3.2.4 Performing a quick data acquisition 

To perform a quick data log of the two channels as defined in the previous section, 

connect appropriate sensors to the C2000 Midbox inputs associated to the channel 

definitions. The C2000 Midbox will report default values without real sensors connected. 

Switch to the graph panel by selecting View » Show Panel » Graph Panel (shortcut key 

F4) from the drop down menu. You will be presented with the graph panel of the C2000 

software. Here, data is presented to you in a graphical plot form. 



 

Page 18 

The graph is automatically configured to plot the data from those indicators created in the 

Super Panel. For this example, the two channels we associated with our front panel 

indicators are plotted on y-axes that match their engineering units respectively. 

Select Start Log from the banner, or select Data » Log Mode » Begin Logging 

(shortcut key F6) to start an acquisition process. The Begin Logging window pops up. 

Choose Continuous from the Logging Mode list, enter 200 into the Sample Rate (Hz) 

field and 10 into the Sample Time (secs) field. Optionally, enter data into the text fields 

for Title, Customer etc. Press Start Logging to begin the log. 

 

Figure 3.10 The Begin Logging window 

The Logging… information strip will appear across the top of the panel indicating that a 

logging process is underway. Live data will be drawn in the graph plot during the 

acquisition process. 
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Figure 3.11 Example output from a Continuous data acquisition process 

Note: Only default values will be returned from the C2000 Midbox without real sensors 

connected to the configured channels. 

Once the acquisition is complete, the C2000 software will receive the logged data from 

the C2000 Midbox and pop up the Logging Complete window. Change the Filename 

prefix from datafile to example, optionally choose to alter any of the text fields, and 

then select Save Data. 

The data will be presented in the graph panel plot. From here you can zoom and pan the 

data using the plot tools located at the top left of the panel area. 

Note: The Super Panel will continue to show live data following a log process. To 

return to a live data mode in the Graph Panel, select the Plot Live Data checkbox 

located toward the bottom right. 

3.2.5 Generating a Report 

To generate a report of the data, including headers, tabulated data and a snapshot of the 

graph, select Report from the banner (shortcut key F7). The report panel will be shown. 

A tabulated form of the logged data is presented, alongside options for customising the 

format of the report. 

Change Selected Data to Last of Range in the Certificate of Test Options section, 

then select Generate under Generate Report… 
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Figure 3.12 The Report Generation panel 

A report viewer window will pop up, displaying the generated report as a PDF document. 

To print or save the document, use the Print and Save As shortcuts located towards the 

top left of the preview window. To close the window, select the cross icon in the title bar, 

or use Alt-F4. 
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Figure 3.13 An example Certificate of Test Report shown in the Report Preview window 
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4. Channel Configuration 
The Channel Configuration window allows you to define channels for each connected 

sensor on the C2000 Midbox. Virtual channels can also be defined for the creation of 

simulated data based on real channel data. 

To access the Channel Configuration window, select Data » Configure Channels from 

the drop down menu, or use the shortcut Ctrl+C. 

When changes are made to the channel configuration, C2000 will attempt to propagate 

relevant changes back to any associated panel indicators and slides. 

Note: Panel indicators maintain their own specific unit display type. Therefore, if a 

channel defined in units of Pascal was switched to Bar, any associated panel indicators 

would maintain their specific pressure units. If a Channel’s base units were redefined 

from Pressure to, say, Flow Rate, all associated panel indicators would switch to a Flow 

Rate unit to maintain data conversion integrity. 

The channel configuration definitions are embedded into the layout information and the 

C2000 data files created following each log process. When loading a data file, the 

channel configuration embedded within that file must match that of the current layout for 

the data to be correctly imported. 

Note: Changing the channel configuration for a layout which has existing data files will 

result in those data files becoming incompatible with the open layout. Therefore, it is 

strongly recommended not to make alterations to the channel configuration of a layout 

file once data acquisition has been performed. Instead, create and work with a copy of 

the layout, making any channel configuration alterations to the copy. 

4.1 Hard Channels 

Hard channels are channels that relate directly to a module and line of the C2000 

Midbox. There are up to eight C2000 Midbox modules available, with up to eight lines 

on each module. 

Analogue current modules each have eight inputs. Connect sensors with a signal range of 

between 4-20 mA. 

Frequency modules each have six inputs. Connect sensors that produce a standard TTL 

pulse signal. 

4.1.1 Defining a Hard Channel 

To define a new hard channel, either double-click an empty line in the hard channels 

table, or select New. The Configure Hard Channel window is shown with blank details in 

the fields. Populate the fields to define the new channel, and select OK. 

4.1.1.1 Configure Hard Channel Window 

The Configure Hard Channel window presents the user with all the properties of a hard 

channel. From here all settings can be modified. 



 

Page 23 

 Channel Name The name identifier for the new channel 

 Signal Type The signal type (current or frequency) for the new 

channel 

 Hardware Line The physical module and channel input on the C2000 

Midbox 

 Sensor Type The units category of reported data from the sensor 

 Calibration Units The specific engineering units for the data reported by 

the sensor for calibration 

The Custom Units button opens the Custom Units window from where custom unit 

definitions can be created. See Section 4.3 Custom Units for more details on Custom 

Units. 

The Calibration button opens the Calibrate Hard Channel window. 

4.1.1.2 Calibrate Hard Channel 

The Calibrate Hard Channel window displays options specific to the signal type and 

sensor type of the channel under configuration. When the Advanced button is depressed, 

further options are presented to the user for improved calibration handling. 

For all calibration types, the option to define the Precision in decimal places is 

available. This option allows for the sensor precision to be declared. For example, to have 

data rounded to the first decimal place, enter 1 into the Precision in decimal places 

field. Subsequently, all digital indicators on the Super Panel and Normal Panels will 

show values to one decimal place precisely. 

Current type channels – Simple calibration 

For a simple calibration of a current type sensor, enter the sensor’s reading for 4 mA and 

likewise for 20 mA into the two fields. A linear calibration will be calculated from the 

two input values after you select OK. 

Current type channels – Advanced calibration 

In Advanced calibration mode, one may enter the offset and multiplier for the linear 

calibration directly, or create a live calibration for the sensor using the linear trend line 

tool. 

To enter the offset and multiplier values for a linear calibration, enter values into Offset 

Correction and Multiplier Correction and select OK. 

To create a linear calibration from values other than 4 mA and 20 mA, use the linear 

trend tool. Enter the sensor readings and the hardware values for the sensor (for example 

100 l/min and 0.005 A for a flow rate sensor) and press Record. Do this for as many 

points as you wish (a minimum of two is required for the calibration to work, the more 

you enter the more accurate the resultant linear calibration). Then select Calculate 

Linear Calibration to perform a best fit to the recorded data points. The Offset 

Correction and Multiplier Correction fields will be completed automatically. 
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If you have a known sensor reading, such as that provided by a calibrated device, you can 

turn on Get Measured Values. Live raw data from the C2000 Midbox is then fed 

directly to the Hardware value field for the module and line of the channel. 

For Advanced calibrations, the Deadband zone field is presented. This field reduces any 

incoming data from the sensor that falls within the deadband range to zero. This feature is 

useful for preventing slight noise or sensor drift from interfering with a true zero 

response. 

Frequency type channels – Simple calibration 

Frequency type channels are divided into two categories 

 Flow sensors 

 Speed sensors 

Flow sensors are shipped with a calibrated K Factor value that the C2000 can directly use 

to calibrate your sensor. For the simple K Factor calibration panel, choose the sensor 

model from the Part Reference drop down list. The C2000 will automatically select the 

K Factor for your sensor. 

For Speed sensors the number of pulses per revolution needs to be entered into the 

Pulses per revolution field. 

Frequency type channels – Advanced calibration 

For Flow sensors, choose the sensor model from the Part Reference drop down list. 

The default K Factor for that model will be entered into the K Factor field. Replace this 

default K Factor with your sensors calibrated value. 

For Speed sensors, enter the number of reported pulses per revolution into the Pulse per 

revolution field, and select Convert. This will convert the PPR value into the appropriate 

Offset and Multiplier values. You may correct these value manually if you wish. 

For Advanced calibrations, the Deadband zone field is presented. This field reduces any 

incoming data from the sensor that falls within the deadband range to zero. This feature is 

useful for preventing slight noise or sensor drift from interfering with a true zero 

response. 

4.1.2 Modifying an Existing Hard Channel 

To modify a defined channel in the hard channels table highlight the channel and then 

select Modify. The channel details are presented in the Configure Hard Channels 

window.  

4.1.3 Deleting an Existing Hard Channel 

To delete a defined channel from the hard channels table, select the channel in the table 

and select Erase. The channel definition will be removed from the table. 
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4.1.4 Reorganising Hard Channels 

The order in which defined hard channels appear in the table can be reorganised by 

selecting a hard channel in the table and selecting either Move Up or Move Down. 

4.2 Virtual Channels 

Virtual channels are channels that use a combination of real and/or other virtual channels 

with simple mathematical operators to create a new simulated channel. Virtual channels 

can be used to create new results based on a number of real channels that might follow a 

simple formula. For example, creating a virtual channel that is the subtraction of one 

pressure from another would provide a new channel representative of differential 

pressure. This could then be displayed and plotted just like any real channel. 

4.2.1 Defining a Virtual Channel 

To define a new virtual channel select New under the Virtual Channels list table in the 

Channel Configuration window. The Configure Virtual Channel window is shown with 

blank details in the fields. Populate the fields to define the new channel, and select OK. 

4.2.1.1 Configure Virtual Channel Window 

The Configure Virtual Channel window presents the user with all the properties of a 

virtual channel. From here all settings can be modified. 

 Channel Name The name identifier for the new channel 

 Sensor Type The units category of reported data from the sensor 

 Engineering Units The specific units for the data reported by the sensor 

 First Channel Choose the first channel upon which the virtual channel 

is dependent. This channel can be either real or virtual. 

 Operator Choose a mathematical operator for the virtual channel 

calculation. These include add, subtract, multiply and 

divide with either a numerical constant or another 

channel. 

 Second Channel If the Operator relates to another channel, select that 

second channel from the drop down list. This channel 

can be either real or virtual. 

 Constant If the Operator relates to a constant, enter that constant 

value in this field. 
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Figure 4.1 Example Virtual Channel configuration 

The Custom Units button opens the Custom Units window from where custom unit 

definitions can be created. See Section 4.3 Custom Units for more details on Custom 

Units. 

The option to define the Precision in decimal places is available. This option 

allows for the data precision to be declared. For example, to have data rounded to the first 

decimal place, enter 1 into the Precision in decimal places field. Subsequently, all 

digital indicators on the Super Panel and Normal Panels will show values to one decimal 

place precisely. 

4.2.2 Modifying an Existing Virtual Channel 

To modify a defined channel in the virtual channels table select the channel and then 

select Modify. The channel details are presented in the Configure Virtual Channel 

window.  

4.2.3 Deleting an Existing Virtual Channel 

To delete a defined channel from the virtual channels table, select the channel in the table 

and select Erase. The channel definition will be removed from the table. 

4.2.4 Reorganising Virtual Channels 

The order in which defined virtual channels appear in the table can be reorganised by 

selecting a virtual channel in the table and selecting either Move Up or Move Down. 

4.3 Custom Units 

The C2000 software ships with the following unit definitions 

 Flow Volumetric flow rate, default litres/min (l/min) 

 Power Power, default Watts (W). 

 Pressure Pressure, default (bar) 

 Speed Rotational velocity, default RPM (rpm) 
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 Temperature Temperature, default Celsius (degC) 

 Velocity Translational velocity, default metres/second (m/s) 

A number of standard units are selectable from menus within Channel Configuration 

and Layout Editor. When units are selected the C2000 converts the data as required. 

The user is able to enter bespoke units through the Custom Units Editor. The Custom 

Units Editor is accessible from within the hard and virtual channel configuration 

panels. Once custom units are defined, they can be accessed from the Sensor Type menu 

as Custom. All defined custom units are then listed in the Engineering units list. 

 

Figure 4.2 Custom Units Editor window 

To create a new custom unit, select New from the Custom Units Editor. To modify an 

existing custom unit, select the custom unit from the table and select Modify. To delete a 

custom unit, select the unit from the table and select Erase. 

Note: No changes are applied to the configured custom units until the OK button is 

pressed. Selecting Cancel will exit the Custom Units Editor window without applying any 

of the changes to the list of custom units. 

Note: Custom units are saved to the layout definition, therefore new layouts will not 

contain any previously defined custom units. To create a new layout that contains any 

previously defined custom units, create a copy of the open layout instead. 

4.3.1 Custom Unit Properties 

When creating a new, or modifying an existing custom unit, the Custom Unit Properties 

window is used. This window shows the two required fields for defining a new custom 

unit. 

 Custom Unit Title The full title of the custom unit, e.g. Relative 

Humidity. 

 Custom Unit Units The short form for the units, e.g. RH%. 

The formatted appearance for the custom unit is presented beneath the two fields, e.g. for 

the details above Relative Humidity (RH%).  

Note: Ensure no brackets are used in the Title definition. 

Select OK to create the new custom unit. 
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Select Cancel to abort the creation of a new custom unit. 
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5. Layouts 
A layout is used to manage your use of the C2000 system. A layout must be created in 

order to save all your channel definitions, custom units and panel configurations. Each 

log process creates a data file that is tied to the open layout, allowing you to open saved 

data files and display the logged data effectively. 

A saved layout stores the following information 

 All Super Panel indicator, slide and title definitions 

 All Normal Panel 1 and 2 indicator, slide and title definitions 

 Currently defined Channels 

 Currently defined Custom Units 

 Certificate of Test report header images 

 All Live Data smoothing settings 

It is recommended that a new layout be created for every variation of channel 

configuration you need. This can easily be achieved by copying a layout, then altering 

your panel layouts and channel definitions. 

5.1 Layout Management 

5.1.1 Creating an empty layout 

To create a new blank layout that contains no defined channels, nor panel indicators and 

slides, select File » Layout Manager from the drop down menu (shortcut Ctrl+L). The 

Layout Manager window will appear. Select New, and enter a name for the new layout. 

Any currently open layout will be closed and the new layout created and opened. 

5.1.2 Creating a copy of a layout 

To create a copy of any layout, use the Layout Manager window. The Layout Manager 

window can be accessed by selecting File » Layout Manager from the drop down menu 

(shortcut Ctrl+L). 

Within the Layout Manager window, select the layout you wish to copy from the table, 

and select Copy. Enter a new layout title for the copy, and select OK. 

To load the new copied layout, select the layout from the table and select Load. Any 

currently open layout will be closed and the new layout opened. 

The copied layout will contain the defined channels, custom units, panel designs and 

report images from the original layout. The data files and analysis files will not be 

copied. 
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5.1.3 Deleting a layout 

Layout definitions can be deleted from the Layout Manager window. The Layout 

Manager window can be accessed by selecting File » Layout Manager from the drop 

down menu (shortcut Ctrl+L). 

To delete a layout, select the layout from the table in the Layout Manager window and 

then select Delete. The layout and any associated data files will be deleted from the PC. 

Note that the currently opened layout cannot be deleted. 

Note: Once a layout has been deleted, neither it nor the data files associated with it can 

be recovered from within the C2000 software. 

5.2 Editing the Layout Panels 

There are four configurable panels for presenting data to the user. The first three allow 

for the creation of digital indicators and slides for presenting the acquired data. The 

fourth panel presents the data in a customisable graphical plot. 

These panels are defined as follows: 

 Super Panel The primary panel, upon which 12 large digital 

indicators, slides and titles can be created. 

 Normal Panel 1 Similar to the Super Panel. 48 small indicators and slides 

can be created. 12 titles can be created 

 Normal Panel 2 A second panel with the same features as Normal Panel 

1. 

 Graph Panel A graphical plot of channel data. 

To edit the layout of indicator and slides in the Super Panel and Normal Panels 1 and 2, 

the user must enter Configuration Mode. Select View » Configure » Configure Panels 

from the drop down menu (shortcut Ctrl+E). The correct password must be entered in 

the password dialogue box (the password is webtec). 

5.2.1 Super Panel 

The Super Panel, as with the two Normal Panels, allows you to create and configure a 

number of digital indicators and slide indicators for displaying data from the C2000 

Midbox. Digital indicators display the data in a numerical form whereas slide indicators 

use a horizontal bar to graphically represent the data. 

5.2.1.1 Creating indicators 

To create a new digital indicator or slide, click the right mouse button within a region of 

free space on the panel to reveal the configuration mode menu. Select either New Digital 

or New Slide to create a new digital or slide indicator. The new indicator will have the 

default title New Digital or New Slide. 
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To move an indicator from its current location, simply click and hold on the indicator 

with the left mouse button and move the indicator to the desired location. Release the 

mouse button to drop the indicator. 

By default the C2000 snaps indicators to a grid to assist in aligning indicators on the 

panel. The snap to grid option can be disabled from the menu. Select View » 

Configure » Snap to grid to uncheck this option and disable grid snapping. To re-

enable, simply select the same menu item once more. 

Note: There is a total indicator and slide count limit of 12 for the Super Panel. 

5.2.1.2 Channel Association 

To display data in an indicator it must be associated with one of your configured 

channels. By default, newly created indicators are not associated with any channel.  

To associate an indicator with a channel, click an indicator with the right mouse button to 

bring up the configuration mode menu. Under Associate you will find a list of all 

configured channels, both hard and virtual. Simply select the channel you wish the 

indicator to be associated with from the list. 

Only one channel can be associated to an indicator, but any number of indicators can be 

associated to a channel. Any indicators left without an associated channel will have their 

titles set to Unassociated and their appearance will be ghosted upon exiting 

configuration mode. 

Note: The number of decimal places shown in a digital indicator is set within the 

associated channel definition. 

5.2.1.3 Changing the displayed units 

Upon first association with a channel, the indicator will display data in the declared units 

of that channel. However, indicators can convert the data and display those values in any 

other unit. This feature may prove useful for converting data acquired from a sensor that 

acquires in one system of measurement to another system of measurement. For example, 

one could report the pressure from a sensor calibrated for pounds per square inch in 

Pascal, or bar, without having to adjust the calibration multiplier. 

To change the displayed units for an indicator, use the configuration mode shortcut menu 

and select the desired units from the Display Units item. The unit short form within the 

title of the indicator will then display the chosen units. 

5.2.1.4 Peak recording 

It is possible to set an indicator to remember the peak value, called Peak Recording. 

When a digital indicator is set to peak recording it will only show the peak value at all 

times. When a slide indicator is set to peak recording, a small needle is displayed above 

the scale that reports the peak value. 

Titles for indicators with peak recording activated show a carat symbol, ^, for easy 

identification. 
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To activate peak recording for any indicator, right click the indicator and select Show 

Peak from the configuration mode menu. To disable peak recording, re-select the menu 

item. 

During monitoring and acquisition it is sometimes desirable to reset the peak values of all 

indicators to clear their memory of previous data. This can be achieved at any time by 

selecting View > Clear Peak Values from the drop down menu. 

5.2.1.5 Titles 

Titles can be created to help identify regions of the panel and group indicators and slides. 

Titles are single lines of editable text. 

To create a title, click the right mouse button within a region of free space on the panel to 

reveal the configuration mode menu. Select New Title from the menu. A new title will be 

created with the default content New Title. 

To move a title from its current location, simply click and hold on the title with the left 

mouse button and move the title to the desired location. Release the mouse button to drop 

the title. 

To edit the content, triple click the title to select all text and begin typing your new 

content to replace the existing text. Alternatively, single click within the title and use the 

delete key to erase the existing text, then enter your new content. 

Note: There is a title count limit of 12. 

5.2.1.6 Deleting indicators and titles 

All indicators and titles can be deleted by clicking the object with the right mouse button 

and selecting Delete from the configuration mode menu. 

To delete all indicators and titles from a panel, select View » Configure » Clear Panel to 

remove all objects from the current panel. 

To delete all indicators and titles from all panels, select View » Configure » Clear All 

Panels to remove all objects from all panels. 

5.2.2 Normal Panels 1 & 2 

There are two Normal Panels in the C2000 software. These can be accessed through the 

menu items View » Show Panel » Normal 1 (shortcut F2) and View » Show Panel » 

Normal 2 (shortcut F3). 

The Normal Panels provide the same features as the Super Panel, with the exception that 

the indicators and titles are smaller in size. Consequently, more indicators can be created 

within the Normal Panels than the Super Panel. 

To enter edit mode, create, modify or delete indicators, slides and title, follow the 

instructions listed in the Super Panel section 5.2.1 Super Panel. 

Note: There is a total indicator and slide count limit of 48 for Normal Panels. There is 

also a title count limit of 12. 
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5.2.3 Graph Panel 

The Graph Panel presents acquired data to the operator in a graphical plot. The graph is 

automatically configured to present the data from those channels associated with the 

indicators and slides of the Super Panel. A list of available channels is presented in the 

table to the right hand side of the panel, coupled with the channels’ latest data value. 

The Graph Panel can be accessed through the menu item View » Show Panel » Graph 

Panel (shortcut F4). 

Unlike the Super Panel and Normal Panels, the configuration of the graph panel can be 

customised at any time without needing to enter Configuration Mode. For more details 

see Section 5.2.3.1 Configuring the Graph. 

Note: Changes to the Super Panel layout cause the Graph Panel to be automatically 

reconfigured to display those channels associated with the Super Panel indicators. 

5.2.3.1 Configuring the Graph 

The plots presented within the graph can be customised using the controls available 

within the Graph Panel. 

Each channel available for plotting is tabulated alongside its latest data value and a 

checkbox. To disable a channel in the graph, select the checkbox beside the channel 

name in the table. The channel data will then be removed from the graph plot, and its 

entry removed from the legend. 

To re-enable a channel in the graph, reselect the checkbox beside the channel name. The 

channel will be reinserted into the list of plotted channels. 

By default, the graph plots data against a relative time axis. The origin of the x-axis is 

then 0, representing the point at which data acquisition began. Alternatively, the x-axis 

can show absolute time, or data from one of the available channels. To change the data 

used for the x-axis, simply select the Horizontal Axis listbox and select an entry from 

the list. When switching from a time to a channel for the horizontal axis, the selected 

channel will be deselected in the table. When switching back to a time axis, the channel 

will need to be reselected in the table for it to be plotted in the graph. 

The colours, symbols and line styles used to draw each plot in the graph are represented 

within the legend. These can be changed by selecting the legend glyph with the left 

mouse button to show a shortcut menu of options for customising the properties of each 

plot. 

The Plot Live Data checkbox can be used to stop and start the presentation of live data 

in the graph plot. Following a log process, this item is automatically unchecked to permit 

the plotting of the logged data in the graph plot. To recommence plotting of live data, 

simply recheck this item. 

The auto-scaling option turns on and off automatic scale adjustments to the graph. With 

auto-scaling on, all axes will be adjusted to fit the data within the graph. Turn off auto-

scaling to permit manual adjustment of the axes. 

Note: Live data can only be plotted if Monitoring is active. 
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6. Data Logging 
You can acquire data from the C2000 Midbox system with one of three acquisition 

techniques. Acquired data can then be saved to a C2000 data file and reports generated. 

The data can then also be loaded in to the Analysis panel tool for comparison with other 

previously acquired data. 

The three acquisition methods available are: 

 Continuous Acquistion at a constant sampling rate for a fixed period 

of time that begins immediately. 

 Profile Acquisition at a constant sampling rate for a fixed period 

of time initiated by a trigger point. Log period can be 

before and/or after the trigger point. 

 Log on Keypress Operator-controlled acquisition. 

The C2000 logs data from all defined channels when performing a log process. The 

Graph Panel automatically plots those channels associated with indicators on the Super 

Panel. To graph any other channel, import the saved data file from within the Analysis 

panel. To plot all channels, see Section 9.4 Importing data files into a spreadsheet 

package. 

6.1 Performing a Log Process 

To perform a data log process, select Start Log from the banner (shortcut F6), or select 

Data » Log Mode » Begin Logging from the drop down menu; The Begin Logging 

window will appear. Populate the fields and select Start Logging to begin the log 

process. 

The top half of the Begin Logging window contains the user editable string fields that 

appear in the header of reports. Use these fields to record information related to the test. 

The lower half of the Begin Logging window contains the log process settings: 

 Logging Mode Continuous, Profile or Log On Keypress log mode 

 Sample Rate (Hz) The sample rate of the acquisition (not available 

for Log On Keypress log mode) 

 Sample Points The number of sample points for the current log 

(not available for Log On Keypress mode) 

 Sample Time (secs) The log process time, equal to the division of 

Sample Points by Sample Rate (not available for 

Log On Keypress mode) 

 Pre-Trigger Sample Points The number of sample points to keep prior to the 

trigger block (only available for Profile log mode) 
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 Trigger Detection The trigger mode, either rising edge or falling edge 

(only available for Profile log mode) 

 Channel The trigger channel (only available for Profile log 

mode) 

 Threshold Value The value at which triggering is set (only available 

for Profile log mode) 

 Filter Filter type of the acquired data setting. 

 Filter Width The width of the filter window (only available 

when Filter is set to Smoothing Window) 

Set your desired log mode and log settings and select Start Logging to begin the log 

process. 

Following a successful log process, the data will be downloaded from the C2000 Midbox 

and processed. The data is then presented in the Graph Panel graph and the Logging 

Complete window will appear. The Filename prefix field allows you to enter filename 

prefix characters that can be used as part of the automatically generated data file 

filename. Alternatively, select and replace the content of the suggested data file filename 

in the Suggested filename field. You are also given a second opportunity to edit the 

report header fields before saving. 

Select Save Data to save the data to file, or Cancel to skip saving of the data. 

Note: If you select Cancel, you can still save the data at a later time by selecting File » 

Save Test Data. The data file filename entered in the Suggested filename field above 

will be used to save the data file. 

6.1.1 Continuous Log Mode 

A continuous mode log process will acquire data from the C2000 Midbox at a constant 

sample rate until the desired number of sample points is acquired. To perform a 

Continuous mode log, set the Logging Mode to Continuous, set the Sample Rate and 

the desired number of Sample Points (or the desired Sample Time (sec)). 

To abort a Continuous log process before the requested number of samples have been 

acquired, select Abort Log from the banner, select Data » Log Mode » Stop Logging 

from the drop down menu or use the keyboard shortcut F6. The sample points acquired so 

far will be downloaded from the C2000 Midbox. 

6.1.2 Profile Log Mode 

To set up a log process that listens for a particular value on a channel to act as a trigger, 

choose Profile from the Logging Mode list. This will reveal the Trigger settings. Choose 

the channel that will act as the trigger channel from the Channel list, and select a trigger 

mode from the Trigger Detection list. A trigger mode of Rising Edge will activate the 

trigger when the channel value rises above the threshold value. Conversely, a Falling 

Edge will activate the trigger when the channel value falls below the threshold value. 

Enter the threshold value into the Threshold Value field. 
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Finally, if a number of sample points prior to the trigger point are required, enter a value 

into the Pre-Trigger Sample Points field. This field must be smaller than the Sample 

Points field. For example, a Pre-Trigger Sample Points count of 500 with a Sample 

Points count of 1000 would return a data log of 1000 sample points, with 500 samples 

acquired before the trigger point and 500 samples following the trigger point. 

To abort a Profile log process, select Abort Log from the banner, select Data » Log 

Mode » Stop Logging from the drop down menu or use the keyboard shortcut F6.  

Note: Aborting a Profile log will provide no data. 

6.1.3 Log On Keypress Log Mode 

To begin a Log On Keypress log process, set the Logging Mode to On Key Press. For a 

Log On Keypress log mode the sample rate, count and triggering options are not 

applicable. Data points are logged individually each time the Spacebar is depressed. To 

begin logging, select Start Logging. 

Live data will be presented in the four panels of the C2000 software. You can quickly 

switch panels using the F1 to F4 shortcut keys. To take a single sample, press the 

Spacebar. A pop up will indicate that a single block of data has been recorded. Continue 

taking samples with the Spacebar. 

Note: The Log On Keypress logging method logs to file the data as it appears on the 

panels. Therefore, any Live Data Smoothing options that influence the live data also 

affect the logged data. Live Data Smoothing does not influence data captured through a 

Continuous or Profile logging method. 

To review the data so far acquired within a Log On Keypress acquisition, press the Enter 

key. This will switch the Super Panel from Live mode to Review mode. In Review mode 

the recorded data can be viewed in the Super Panel indicators using the Up Arrow and 

Down Arrow keys. The Logging information banner will report the block number 

currently under review. New acquisitions can still be performed with the Spacebar in 

Review mode. To return to Live mode, press the Enter key. 

To terminate a Log On Keypress log, either press the Escape key, select Abort Log from 

the banner, select Data » Log Mode » Stop Logging from the drop down menu or use 

the keyboard shortcut F6. 

6.2 Reviewing Acquired Data 

Following a successful data acquisition process, the data is presented in the Graph Panel 

graph. From here the data can be manipulated in a number of ways to customise the view. 

Using the graph tools located toward the upper left of the Graph panel, one can zoom and 

pan the data in a variety of methods. Channels can be activated and deactivated using the 

table toward the lower right. The choice of horizontal axis data can be switched from 

time to any of the logged channels using the Horizontal Axis drop down listbox, and 

the styles used for plotting each channel can be altered from the legend. 

Please refer to section 5.2.3 Graph Panel for more details on configuring the Graph 

panel. 
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To review the acquired data alongside other data from a previous log process, please refer 

to Section 8 Analysis Tools. 

Note: To inspect the data in a tabular format, please refer to Section 7 Report 

Generation. 

Note: The Graph Panel graph will only present data for the associated indicators on the 

Super Panel, however the data test file contains data for all defined channels. To see the 

logged data for channels not associated with any Super Panel indicators, import the data 

test file into the Analysis Panel. 
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7. Report Generation 
The C2000 software can generate a Certificate of Test report of your test data. To create a 

report there must be logged data available, such as directly following a log process or 

loading of a data file. 

To generate a report, select Report from the banner (shortcut key F7). The C2000 

software will present the Report Generation panel. 

 

Figure 7.1 The Report Generation panel 

The report panel contains a number of options, as well as a tabular representation of the 

logged data. For Certificate of Test reports, the report type information field will show 

Certificate of Test. 

The C2000 can also generate snapshot reports. Snapshot reports contain only a snapshot 

image of your current view. For Snapshot reports, the report type field will show 

Snapshot. For more information on Snapshot reports, see Section 7.2 Snapshot Report. 

Reports can also be produced from the Analysis panel (see Section 8 Analysis Tools). 

For Analysis reports, the report type field will show Analysis. For more information on 

Analysis reports, see Section 7.3 Analysis Report. 

7.1 Certificate of Test Report 

To generate a Certificate of Test report, select Report from the banner (shortcut key F7). 

The C2000 software will present the Report Generation panel. 
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For a Certificate of Test report, select from the Certificate of Test Options to customise 

the report appearance. 

7.1.1 Customising a Certificate of Test Report 

The Certificate of Test Options under the Report Generation panel provide the following 

settings: 

 Title Text The title text for the Certificate of Test report, 

default Certificate of Test. 

 Left Image Select to change the Image that appears in the left 

hand box of the report header. 

 Right Image Select to change the Image that appears in the right 

hand box of the report header. 

 Show Information Block Select to the show the custom text fields block of 

the Certificate of Test report. 

 Show Test Data Block Select to include the table of data in the Certificate 

of Test report. 

 Selected Data listbox When including the table of data in the report, 

select from Selected Data, Last of Range or First of 

Range. Note that choosing Selected Data when all 

data is selected can result in a long table of data 

spanning numerous pages. 

 Range fields (0 to 999) The selected range of table data 

 Show Graphic Select to include an image of the Graph Panel in 

the report. The Graph Panel graph time axis range 

will be adjusted to show only the Range fields 

selected range. 

To generate the report, choose either Portrait or Landscape orientation from the listbox 

under Generate Report… and select Generate. 

The Graph Panel graph will be adjusted to match the selected range of data, and an 

Adobe PDF format report will be generated and displayed in a separate preview window. 
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Figure 7.2 An example Certificate of Test Report shown in the Report Preview window 

7.2 Snapshot Report 

A Snapshot report is a very simple report that places a quick snapshot of the current panel 

view into a basic PDF report with a simple header. 

To achieve a Snapshot report, select View » Snapshot Report from the drop down 

menu. A Snapshot report can be created from any C2000 panel. 

The Report Preview window will show the basic report. The Print and Save tools also 

apply to Snapshot reports, allowing the quick creation, distribution and printing of basic 

reports. 
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Figure 7.3 Example Snapshot Report for the Super Panel 

7.3 Analysis Report 

An Analysis report can be produced by selecting the Report button on the Analysis panel. 

Data from the Analysis graph will be copied into the report table for review. 

An Analysis report is similar to a Certificate of Test report. The information block data is 

drawn from the first of the two data files imported. You can use the Certificate of Test 

Options to modify the appearance of the report. Please see Section 7.1.1 Customising a 

Certificate of Test Report for more details on customising the appearance of reports. 

Note: Changing the range of the data in the report data table will only affect the actual 

report table and not adjust the Analysis panel graph scale. 

7.4 Printing and Saving a Report 

A report can be printed from the Report Preview window. The Report Preview window 

utilises the Adobe Reader plug-in and includes the standard Adobe Reader tools. 

To Print the PDF report, select the Print icon from the Adobe Reader icon bar (shortcut 

key Ctrl+P). A standard print dialogue box is shown. Make any changes to the Print 

settings and select OK (shortcut Enter). 

To Save the PDF report, select the Save icon from the Adobe Reader icon bar (shortcut 

key Ctrl+S). A standard file dialogue window is shown. Choose a filename and select 

Save (shortcut Enter) to save a copy of the report. 

Note: Certificate of Test reports, Snapshot reports and Analysis report can all be saved 

and printed from the Report Preview window. 
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7.5 Using Different Images in Reports 

Every time a new layout is created through the Layout Manager the C2000 program 

copies reportrightimage.jpg and reportleftimage.jpg from the C2000 

Configuration folder under c:\Program Files\C2000 (see figure 7.4) in to the newly 

created Projects file. If these two image files are not present in the C2000 Configuration 

folder (figure 7.4) an error will occur when new layouts are created.  

Where alternative images are used they can be of any size as the C2000 program resizes 

them appropriately for the Report form. 

 

To use different images for reports two approaches can be taken: 

 

1. Permanently replace the default images:  

Replace the reportrightimage.jpg and reportleftimage.jpg images in 

Program Files>>C2000>>Configuration with the required files. Ensure the file 

names are the same as those they are replacing! 

Every time a new layout is created the new left and right images will be copied to 

the new project file and used in report generation by default. 

 

2. Use different images for different layouts: 
Save the required images in the respective projects folder (see figure 7.5 for an 

example). Ensure you have the appropriate layout loaded, navigate to the report 

generation window and click the right image button and select the required image 

from the list. Repeat for the left image. 

Every time this layout is loaded the new images (project specific) will be used in 

report generation. NB. The new images are resized and renamed 

reportrightimage.jpg and reportleftimage.jpg within the specific folder  
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Figure 7.4. Location of master left and right images. 

 

 

 

Figure 7.5. Location of user left and right images. 
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8. Analysis Tools 
The Analysis tools panel allows for the comparison of two test data files. A selected set 

of channel data can be imported and simultaneously displayed in one graph. From here, 

all acquired data within a saved test data file can be accessed for analysis. 

To access the Analysis tools, select Tools » Analysis from the drop down menu. The 

Analysis Panel will be displayed, containing a graphical display similar to that of the 

Graph Panel and a selection of tools for importing and exporting data. 

 

Figure 9.1 Example Analysis panel 

8.1 Importing Data into Analysis 

Select Import from the Analysis Panel. The Analysis Data window will appear. In this 

window use the Browse buttons to select the two test data files to be imported and 

compared in the graph. The Available Channels tables will populate with the data 

contained within the selected data files. Select the checkbox beside those channels that 

you wish to have imported. 

Note: C2000 log files contain data for all defined channels. Therefore you can select 

from your entire defined channel list when importing a data test file. 
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Figure 9.2 Example Import Analysis Data window 

To load the selected channel data choose OK, otherwise choose Cancel to abort the import 

process. 

The selected channels will be loaded from the test data files and combined in the 

Analysis Panel graph. As with the Graph Panel graph, appropriate y-axes will be created 

for the channel data. Within the legend, the test data filename will be appended to the 

channel title to aid identification. 

Note: The combined channel title and data filename text used in the legends is truncated 

to a maximum of 23 characters. 

8.2 Customising the Analysis Graph 

The Analysis Panel graph responds in the same manner to the Graph Panel graph. 

Therefore, please see Section 5.2.3.1 Configuring the Graph for details on customising 

the graphical display. 

8.3 Analysis Report 

To generate a report of the Analysis panel data, select the Report button in the lower 

right corner of the Analysis panel. The Report panel will be shown populated with the 

data contained within the Analysis panel graph. See Section 7.3 Analysis Report for 

more details on generating an Analysis report. 
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9. Importing and Exporting Files 
The C2000 permits export of acquired data files to other formats. This may be useful for 

importing the data into other packages, such as spreadsheet packages, for further data 

analysis. 

9.1 Exporting a data file 

To export a data file, first either acquire new data or load an existing data file into the 

C2000.Then, select Save As Test Data from the File menu, and choose a destination 

filename for the file. Ensure you use csv (comma separated value) as the file extension to 

produce an ascii formatted data file. The csv format will ensure the data exists within the 

file in a format easily interpretable by common spreadsheet packages such as Microsoft 

Excel. 

Note: C2000 data files contains logged data for all defined channels. Exporting a data 

file to a third party spreadsheet package will allow for graphing of all logged channels. 

9.2 Exporting an Analysis file 

To export an analysis file in a comma separated value (csv) file format, first navigate to 

the Analysis panel (select Tools » Analysis from the drop –down menu). 

Either Import new data to the analysis graph or Load an existing analysis file. Then 

select Save from the Analysis panel, and choose a destination filename for the file. 

Ensure you select csv (comma separated value) as the file extension to produce an ascii 

formatted analysis file. The csv format will ensure the data exists within the file in a 

format easily interpretable by common spreadsheet packages such as Microsoft Excel. 

9.3 Importing data files into the C2000 

ASCII formatted data and analysis files can be re-imported into the C2000 software. To 

load an ASCII test data file, select File » Import from the drop down menu. Navigate to 

the csv file and select Import. The data will be imported from the file as a standard data 

or analysis file. 

Note: The C2000 software appends checksum characters into all file formats to 

effectively manage data integrity. ASCII formatted data files with edited content will be 

considered of unknown integrity and consequently may not be successfully imported. 

9.4 Importing data files into a spreadsheet 
package 

9.4.1 Importing a CSV formatted data file 

To locate the data within the ascii formatted data file, you will need to skip beyond the 

first 289 lines of the data file. These initial blocks contain the layout and channel 

definitions. Follow the instructions provided with your spreadsheet package for importing 

a csv formatted data file, and jump to line 290. 
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Line 290 represents the channel labels, line 291 contains the units for each channel and 

the acquired data begins at line 292. 

Note: A checksum character is included in the last line of the file. Therefore, remember to 

exclude the last line when importing data from an ascii formatted data file. 

9.4.2 Importing a CSV formatted analysis file 

The data is stored differently within an ascii formatted analysis file to help differentiate 

between the two original source files. No layout information is included, only the channel 

definitions. Follow the instructions provided with your spreadsheet package for importing 

a csv formatted data file, and jump to line 37 of the analysis file. 

The two original source data files are handled sequentially, with definitions for the first 

data file appearing first. The first 36 lines contain the channel definition data. Line 37 

contains the channel labels, line 38 contains the units for each channel and the acquired 

data begins at line 39. 

The definitions for the second source file follow the data of the first source file. 

Therefore, for data containing 500 blocks, the second definition will begin at line 540. 

This again begins with the channel definitions for the second source file, followed by the 

channel labels, the channel units and finally the acquired data. 

Note: A checksum character is included in the last line of the file. Therefore, remember to 

exclude the last line when importing data from an ascii formatted analysis file. 
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10. Troubleshooting 

10.1 Hardware connection 

The C2000 software communicates with the C2000 Midbox hardware through your 

Ethernet network connection. In the event that the hardware cannot be detected: 

 Ensure the Midbox is powered and has had sufficient time to initialise 

(approximately 30 seconds). 

 Check the system network connectivity. Use the Network Connections tools 

within Control Panel to determine connectivity to the Midbox. 

 Use Tools » Connect to attempt to re-establish a connection with the Midbox. If 

this option is not available, first select Tools » Disconnect then retry. 

 Repower the Midbox: Switch off the power to the Midbox cabinet for a full 10 

seconds, then switch on the power. Wait 30 second for the system to initialise 

before attempting to reconnect. If the cabinet is remotely sited, function takes 

approximately 1 minute to complete. 

10.2 Report preview 

When generating reports with a lot of data included in the Test Data Block, it can take a 

significant amount of processing time to compile the data table. To avoid these 

circumstances, reduce the data selection included in the data by choosing either First or 

Last of Selection under Show Test Data Block within the report panel 

Certificate of Test Options. 

The reports are generated in Adobe PDF format. The C2000 software uses the Adobe 

Reader plug-in to display reports in the Report Preview window. If the Report Preview 

window appears blank, ensure that Adobe Reader V8.0, or greater, is installed on the PC. 

Note: Adobe Reader can be downloaded and installed for free from the following Adobe 

website: http://get.adobe.com/reader 

10.3 Navigating the menus with the keyboard 

The C2000 software can mostly be navigated without the use of a mouse. All user panels 

and menu items can be selected through either keyboard shortcut combinations or by 

selecting the TAB key to move the focus box to the desired item and pressing Spacebar 

to select. 

Functions which necessitate use of a mouse include panel configuration, where the click 

and drag capabilities allow movement of indicators and labels, and right-click shortcut 

menus are required. 

10.3.1 Defined keyboard shortcuts 

 Ctrl + C Open the Channel Configuration window 



 

Page 50 

 Ctrl + E Enter / Exit Panel Configuration mode 

 Ctrl + H Open the Help window 

 Ctrl + L Open the Layout Manager window 

 Ctrl + M Enable / Disable Live Data Monitoring 

 Ctrl + S Save the existing layout 

 Ctrl + Shift + S Save a copy of the open layout 

 F1 – F4 Switch between the Super Panel, Normal Panel 1, Normal 

Panel 2 and the Graph Panel 

 F5 Open an existing layout (similar to Ctrl + O) 

 F6 Begin a new data log process 

 F7 Generate a Certificate of Test report 

 Alt + F4 Will exit the C2000 software 

10.3.2 Specialised Keyboard Shortcuts 

 Escape key During a Log On Keypress process, will end the log process 

 Spacebar During a Log On Keypress process, will acquire one block 

of data 

 Enter During a Log On Keypress process, will enter / exit review 

mode 

 Up Arrow In Review mode of a Log On Keypress process, will move 

to the next block for review 

 Down Arrow In Review mode of a Log On Keypress process, will move 

to the previous block for review 
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